Egyedi PHP verzió beállítása könyvtáranként

A cPanel felületen a PHP verzió választás menüpontban ki lehet választani, hogy mi legyen az alapértelmezett PHP verzió a tárhelyen.

Jelenleg az alábbi PHP verziók érhetőek el:

  • PHP 4.4
  • PHP 5.1
  • PHP 5.2
  • PHP 5.3
  • PHP 5.4
  • PHP 5.5
  • PHP 5.6
  • PHP 7.0
  • PHP 7.1
  • PHP 7.2
  • PHP 7.3

Ha nem a natív PHP verzió van a tárhelyen használatban akkor minden PHP verzió esetében ki lehet választani a bekapcsolandó modulokat, illetve néhány php.ini beállítás módosítására is lehetőség van. A PHP modulok esetében fontos odafigyelni, hogy nem elég a jelölőnégyzetekbe pipát tenni, el is kell menteni a beállításokat az oldalon!

Abban az esetben ha valamelyik domain név esetében nem az alapértelmezetten kiválasztott PHP verziót szeretné használni, úgy az adott domain névhez hozzárendelt kezdőkönyvtárban (document_root) kell létrehozni egy .htaccess fájlt, majd abban a következő sorok egyikét kell elhelyezni. A beállítást követően rekurzívan, az összes alkönyvtárra is érvényes lesz a beállítás.

PHP 4.4-es verzió esetében:

AddHandler application/x-httpd-php44 .php .php5 .php4 .php3

PHP 5.1-es verzió esetében:

AddHandler application/x-httpd-php51 .php .php5

PHP 5.2-es verzió esetében:

AddHandler application/x-httpd-php52 .php .php5

PHP 5.3-es verzió esetében:

AddHandler application/x-httpd-php53 .php .php5

PHP 5.4-es verzió esetében:

AddHandler application/x-httpd-php54 .php .php5

PHP 5.5-es verzió esetében:

AddHandler application/x-httpd-php55 .php .php5

PHP 5.6-es verzió esetében:

AddHandler application/x-httpd-php56 .php .php5

PHP 7.0-es verzió esetében:

AddHandler application/x-httpd-php70 .php .php5

PHP 7.1-es verzió esetében:

AddHandler application/x-httpd-php71 .php .php5

PHP 7.2-es verzió esetében:

AddHandler application/x-httpd-php72 .php .php5

PHP 7.3-es verzió esetében:

AddHandler application/x-httpd-php73 .php .php5

A verziónkénti bekapcsolt modulok globális beállítások, de a php.ini beállításokat le lehet cserélni egy .php.ini fájl elhelyezésével, illetve az 5.4-es PHP verziótól kezdődően elhelyezhet egy .user.ini fájlt, amiben egyesével felülbírálhatóak a PHP beállítások az adott könyvtárra (és annak alkönyvtáraira).

  • 13 Felhasználó hasznosnak találta
Segített önnek ez a válasz?

Kapcsolódó cikkek

lsPHP használata a tárhelyen

Mi az lsphp?lsphp - PHP + LSAPI.Mit takar az LSAPI?A LiteSpeed Server Application Programming...